solved this issue by downgrading to 2.0.0-rc.16. Just run a npm install onsenui@2.0.0-rc.16 . The support team is awesome. They responded in a days time and started investigating the issue.