Notice: The Monaca & Onsen UI Community Forum is shutting down.

For Onsen UI bug reports, feature requests and questions, please use the Onsen UI GitHub issues page. For help with Monaca, please contact Monaca Support Team.

Thank you to all our community for your contributions to the forum. We look forward to hearing from you in the new communication channels.

monaca preview error

  • I use monaca CLI to create a project with " Onsen UI and React " category,
    and " Onsen UI v2 React Minimum " template.
    But when I run " monaca preview “,
    It replied:
    ” Failed serving project: Cannot find module ‘tapable’ "

    I tried to run " monaca debug "
    and It became:
    Running Transpiler…
    throw err;

    Error: Cannot find module 'tapable’
    at Function.Module._resolveFilename (module.js:455:15)
    at Function.Module._load (module.js:403:25)
    at Module.require (module.js:483:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> (/Users/MYUSERNAME/.cordova/node_modules/webpack/lib/Compiler.js:6:15)
    at Module._compile (module.js:556:32)
    at Object.Module._extensions…js (module.js:565:10)
    at Module.load (module.js:473:32)
    at tryModuleLoad (module.js:432:12)
    at Function.Module._load (module.js:424:3)

    I tried this on both MacOS Yosemite and Windows 10,
    and both npm 2.15.9 and npm 3.10.3,
    All the same problem…

    Does anyone ever met the same problem and resolved it , Please help me, please.

    Thank you.

  • OK, I found I just need to goto /Users/MYUSERNAME/.cordova/ directory and run " npm install --save tapable " and then anything goes well.
    Hope it helps somebody with the same problem^^

  • Steps to fix-
    Installation in Windows
    When installing Monaca Localkit on Windows, the following screen might show up preventing you from installing the Localkit.

    In order to solve this problem, click More Info. Then, click the Run Anyway button.

    Installation in Mac OS X
    When installing Monaca Localkit in Mac OS X, the following screen might show up preventing you from installing the Localkit.

    In order to solve this problem, do as follows:
    Open the System Preferences and go to Security & Privacy.
    Click Open Anyway.

    1. Now, try installing the app again. It should work on this time.
      Removing Monaca Localkit (for Windows)
      While uninstalling Monaca Localkit, you might not be able to remove its remaining files. In this case, please remove them manually from Program Files folder.
      Incomplete files and folder structure
      Monaca/Cordova projects initially consist of the following files and folders:

    In this section, we will talk about how to fix your project if the www/ or config.xml file is missing.
    Missing www folder
    For standard projects
    The user should create a www folder in the root of the project or restore a previous backup of the folder.
    For Webpack projects
    www folder will be created automatically during the transpiling process. Transpiling is triggered automatically after selecting a project from the project list in the Monaca Localkit if the option is enabled.
    Missing the config.xml file
    This solution works only if your project exists on Monaca Cloud.

    Rachel Gomez