Notice: The Monaca & Onsen UI Community Forum is shutting down.

For Onsen UI bug reports, feature requests and questions, please use the Onsen UI GitHub issues page. For help with Monaca, please contact Monaca Support Team.

Thank you to all our community for your contributions to the forum. We look forward to hearing from you in the new communication channels.

Failed serving project



  • Hi guys,

    I followed the ‘Getting Started’-helloworld tutorial. At the point where I run ‘monaca preview’ I get the following error:

    Failed serving project: monaca.requireTranspile is not a function

    Any suggestions?


  • Onsen UI

    @OrestisZam This is an issue with a dependency version. We will release a new CLI version in the upcoming days fixing this. In the meantime you can find the directory of monaca-cli in your npm installation and modify its package.json: Line #34 "monaca-lib": "^2.0.8",, remove ^ so it becomes "monaca-lib": "2.0.8",. After that run npm install in the directory. I think that will fix it.

    As I said, a new version will be released quite soon if we don’t have (more) problems :)



  • Hello Fran,
    I have applied the changes you suggested but I am still having the error. “Failed serving project: monaca.requireTranspile is not a function”- What do I do please?

    Thanks


  • Onsen UI

    @mykoman Can you check that the installed monaca-lib is 2.0.8 version? It should say it in its package.json.
    Anyway, we will release the new CLI tomorrow with this fixed and many other news :)



  • Nice it works now with the new version! Great