monaca debugger fails on ipad



  • Trying to run the monaca debugger on an ipad air. It works great for me on an iphone 5 and an android tablet, but on the ipad it shows the splash screen and then goes to a blank white screen with only the little monaca square icon in the lower right showing.

    I have targeted the ipad in the ios app configuration, and tried flushing the debugger cache and reloading my app, as well as rebooting the debugger. Any ideas? happy to show the code if it helps.


  • Monaca

    Which version of iPad Air are you using and which version of iOS?



  • Its the ipad air original (air 1?) running ios 9.3.3.
    cordova 5.2.0 in monaca


  • Monaca

    @tony thank you for the info. Does this issue happens with all the projects or just with a specific one?



  • I only have one project going currently. The debugger app runs fine on my iphone 5c, lenovo yoga tab 3 and Moto G phone, just not on the ipad.


  • Monaca

    could you please try to create a new project based on a different template and check if it has the same issue?



  • Okay, another problem has developed since we started talking about this. Now if I try to do a build for ios I get the “app build is failed” message. Android builds work fine. Tried it on debug and on release builds neither worked. I created a new “helloworld” project as you suggested using the same private key and upload certificate that (it apparently put that in automatically) and an ios debug build fails on that, too (the android debug build works).

    The first part of the error log for the ios build is below.

    Temporary folder: /private/tmp/monaca/579a336cfd1734dd6131d892
    Downloading project
    Download complete
    Running for 5.2
    Running command: php /private/tmp/monaca/579a336cfd1734dd6131d892/ios/scripts/build_ios.php --path /data/monaca_build_module/5.2 --type 'debug' 2>&1

    Prepare keychain…

    1 key imported.
    Unable to delete certificate matching "iPhone Developer: Tony Stoltzfus (64D2VDH966)"


  • Monaca

    This is a totally different issue and likely is not related to the certificate. Just a few quick hints:

    • If you are using Monaca Backend Plugin, try to remove it and import it again.
    • If you are using external cordova plugins, try to remove them and perform a build.

    Let me know how it goes :)



  • Okay, I disabled the monaca backend plugin and the ios build worked (although I couldn’t save any data in the app).

    Then I re-enabled the plug in and things still worked - so that was a great fix. Thank you!

    So back to the ipad air issue. I ran the ‘helloworld’ app template with no changes, and it seems to be working – at least if the screen is supposed to look like this image:

    0_1470177577113_IMG_0035.jpg

    So apparently it works on another app but not on mine.


  • Monaca

    Do you get any error message on the iPad? Perhaps you are using some deprecated API wich work on some iOS versions but not in others.



  • Here’s all I get:

    resolveAndReadFile content: {“medKeyIdx”:1,“medQuestionIdx”:
    resolveAndReadFile content: {“soundIdx”:1,“soundIdMax”:11}



  • my ipad and iphone are both up to date on ios, and it works on one but not the other



  • @tony That output is the debug output in your app. You can disable that by setting debug, in the phonegap_custom.js file (of your specific project), to false. Those messages were developer output and do not indicate an error, just that, that is the call being made. By making it false, it may make an error more visible.


Log in to reply