APK version code needs to be higher



  • I am setting the APK version code to a number that is defiantly higher than what is being given in the error in both the manifest and in the build configuration on the Monaco cloud build system. It builds successfully but when I go to submit the APK to the android playstore I get the error: Your APK’s version code needs to be higher than …

    Is there something more I need to do?

    Thanks!



  • @tjkix2006 said:

    APK’s version code needs to be higher than

    Hi man , once i had the same problem .

    A version code is an integer value that represents the version of the application code, relative to other versions.
    So for solution you need to change your version name and version code (increment with 1)and run application once and after export it upload to Google Play.

    Hope it helps you!

    Below a history of my application: https://play.google.com/store/apps/details?id=codigo.flat.leo.moura123684746

    300058 (2.0.0)
    300048 (2.0.0)
    300038 (2.0.0)
    300028 (2.0.0)
    300018 (2.0.0)
    300008 (2.0.0)
    20008 (2.0.0)
    10001 (1.0.1)
    10000 (1.0.0)



  • Thanks for the response. I know what you mean, but I don’t think this is the problem or I must be missing something. I change this value in the android manifest as well as in the ‘build configurations’ in Monaca’s cloud build, then it builds. But when it comes time to submit it to the store it then gives me the error that the version code is not higher than 2016022532, which it is now set to 2016022543, which is indeed higher. So I’m confused…




Log in to reply