Fail to migrate to onsen UI 2 (rc10)



  • On app start angularjs fail and i can see this in chrome’s console

    TypeError: Cannot read property 'childNodes' of undefined
        at compositeLinkFn (file:///android_asset/www/lib/angular/angular.js:8400:36)
        at nodeLinkFn (file:///android_asset/www/lib/angular/angular.js:9088:24)
        at compositeLinkFn (file:///android_asset/www/lib/angular/angular.js:8397:13)
        at nodeLinkFn (file:///android_asset/www/lib/angular/angular.js:9088:24)
        at compositeLinkFn (file:///android_asset/www/lib/angular/angular.js:8397:13)
        at compositeLinkFn (file:///android_asset/www/lib/angular/angular.js:8400:13)
        at publicLinkFn (file:///android_asset/www/lib/angular/angular.js:8277:30)
        at file:///android_asset/www/lib/angular/angular.js:1751:27
        at Scope.$eval (file:///android_asset/www/lib/angular/angular.js:17229:28)
        at Scope.$apply (file:///android_asset/www/lib/angular/angular.js:17329:25) 
    

    angular version is 1.5.5.

    i were using onsen-UI 1.3.8 before tring to migrate and i had no bug.
    Any idea ?

    I’ll try to make a lighter version of my app to try to isolate the bug but at the moment, i have no clue.



  • I’D dig deep enough to found than my bug is related to ons-modal
    I’ve commented this and error disapear :

    <ons-modal var="loginModal">
            <p class="">{{ 'Connecting' | translate }}</p>
            <ons-icon icon="fa-spinner" spin="true" size="40px"></ons-icon> <br />
        </ons-modal>
    


  • @matheos

    nice one :smiley:


Log in to reply