Monaca Onsen UI Discord Chat Github Repo

Command failed with exit code 65 on ios with "dpa99c/cordova-plugin-firebasex" - plugin



  • Hi there

    If I try to build an iOs App with the “dpa99c/cordova-plugin-firebasex” - plugin it fails with the following error. If I remove this plugin, build succeeds.
    I already tried to remove the ‘ü’ and blank within app name, but this did not help.

    Do you have any suggestions? Feel like I crawled the whole web, but I didn´t find something that helps.

    Any help appriciated.

    CLI Version: 11.0.0
    iOS Platform: 6.2.0
    Xcode 13.0

    [01:14:01] /tmp/download/platforms/ios/Schü**** **/Plugins/monaca-plugin-monaca-core/Monaca.m:83:48: warning: ‘openURL:’ is deprecated: first deprecated in iOS 10.0 [-Wdeprecated-declarations]
    [01:14:01] [[UIApplication sharedApplication] openURL:[NSURL URLWithString:urlString]];
    [01:14:01] ^~~~~~~
    [01:14:01] openURL:options:completionHandler:
    [01:14:01] In module ‘UIKit’ imported from /Users/builder/Library/Developer/Xcode/DerivedData/Schü
    **_-hjnzjwxomgbtludbjgxoxmopisun/Build/Intermediates.noindex/ArchiveIntermediates/Schü /IntermediateBuildFilesPath/UninstalledProducts/iphoneos/include/Cordova/CDVAvailabilityDeprecated.h:20:
    [01:14:01] /Applications/Xcode_13.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS15.0.sdk/System/Library/Frameworks/UIKit.framework/Headers/UIApplication.h:124:1: note: ‘openURL:’ has been explicitly marked deprecated here
    [01:14:01] - (BOOL)openURL:(NSURL
    )url API_DEPRECATED_WITH_REPLACEMENT(“openURL:options:completionHandler:”, ios(2.0, 10.0)) NS_EXTENSION_UNAVAILABLE_IOS("");
    [01:14:01] ^
    [01:14:01] 1 warning generated.
    [01:14:04] In file included from /tmp/download/platforms/ios/Schü
    * /Plugins/cordova-plugin-firebasex/AppDelegate+FirebasePlugin.m:2:
    [01:14:04] /tmp/download/platforms/ios/Schü
    ****/Plugins/cordova-plugin-firebasex/FirebasePlugin.h:4:9: fatal error: module ‘FirebaseFirestore’ not found
    [01:14:04] @import FirebaseFirestore;
    [01:14:04] ~^~~~~~~~~~~
    [01:14:04] 1 error generated.
    [01:14:04] note: Using new build system
    [01:14:04] note: Planning
    [01:14:04] note: Build preparation complete
    [01:14:04] note: Building targets in parallel
    [01:14:04] /tmp/download/platforms/ios/Pods/Pods.xcodeproj: warning: The iOS deployment target ‘IPHONEOS_DEPLOYMENT_TARGET’ is set to 8.0, but the range of supported deployment target versions is 9.0 to 15.0.99. (in target ‘AppAuth’ from project ‘Pods’)
    [01:14:04] ** ARCHIVE FAILED **
    [01:14:04] xcodebuild: Command failed with exit code 65



  • Problem solved

    I had to add also the Plugin “NIFCloudMB”. In addition I had to remove the “ü” and blank within app name.

    Edit:
    The NIFCloudMB was not the solution. I had to set a specific version of the “dpa99c/cordova-plugin-firebasex” - plugin for ios:
    {
    “name”: “monaca-template-minimum”,
    “version”: “2.2.0”,
    “displayName”: “Monaca Template Minimum”,
    “dependencies”: {
    “cordova-custom-config”: “5.1.1”,
    “cordova-plugin-firebasex”: “11.0.3-cli”,
    “cordova-plugin-splashscreen”: “6.0.1”,
    “cordova-plugin-device”: “2.1.0”
    },
    “scripts”: {
    “monaca:preview”: “npm run dev”,
    “dev”: “browser-sync start -s www/ --watch --port 8080 --ui-port 8081”
    },
    “cordova”: {
    “plugins”: {
    “monaca-plugin-monaca-core”: {},
    “cordova-plugin-device”: {},
    “cordova-plugin-firebasex”: {},
    “cordova-custom-config”: {},
    “cordova-plugin-splashscreen”: {}
    }
    },
    “devDependencies”: {
    “browser-sync”: “~2.27.7”,
    “cordova”: “^11.0.0”
    }
    }

    For Android the current version:
    {
    “name”: “monaca-template-minimum”,
    “version”: “2.2.0”,
    “displayName”: “Monaca Template Minimum”,
    “dependencies”: {
    “cordova-custom-config”: “5.1.1”,
    “cordova-plugin-splashscreen”: “6.0.1”,
    “cordova-plugin-device”: “2.1.0”,
    “cordova-plugin-firebasex”: “git+https://github.com/dpa99c/cordova-plugin-firebasex”
    },
    “scripts”: {
    “monaca:preview”: “npm run dev”,
    “dev”: “browser-sync start -s www/ --watch --port 8080 --ui-port 8081”
    },
    “cordova”: {
    “plugins”: {
    “monaca-plugin-monaca-core”: {},
    “cordova-plugin-device”: {},
    “cordova-custom-config”: {},
    “cordova-plugin-splashscreen”: {},
    “cordova-plugin-firebasex”: {}
    }
    },
    “devDependencies”: {
    “browser-sync”: “~2.27.7”,
    “cordova”: “^11.0.0”
    }
    }