Monaca Onsen UI Discord Chat Github Repo

Line Length HTML Problem - editor.maxTokenizationLineLength



  • Hello everyone

    Because of the large size of the line of the code I have in html page,
    it does not load my entire page so it shows up half.
    and I get the message below on Monaca Cloud IDE

    Tokenization is skipped for long lines for performance reasons.
    This can be configured via editor.maxTokenizationLineLength.

    Is There Any Way to Increase Line Length? and how it can be done, what steps I need to follow?

    P.S. I have already Formatted the html code to one line, but the problem remains.

    Please Help
    Thank you
    Takis


  • administrators

    It looks like the only editor configuration that can be done is through the Config -> Workspace Configuration page but unfortunately it doesn’t seem to include the setting you need. I think the editor used internally is Monaco (with an ‘o’) so you may be able to find some help in its documentation.



  • emccorson thank you for the answer,
    where can i find what you are telling me?

    I think the problem is inside Monaca. I have tried both ways with Monaca CLI / Monaca LocalKit and have not found a solution, it always limits the code length.
    The other thing I’m thinking about is whether it’s an ONSEN UI issue that limits line length.
    I would appreciate if anyone can please find a solution, because I can not proceed with the code of the app.

    Thank you


  • administrators

    It’s specifically a setting in Monaca Cloud IDE, but I believe that it is not possible for users to set it. Is there still a problem once you split the lines?



  • Υes i saw that you can not set Monaca Cloud IDE settings
    Υes the problem exists.
    anyone can try it, making 1 or 2 page/s with long lines and will see that the text is cut.


  • administrators

    Unfortunately it doesn’t seem there is much that can be done about it from the user-end. I meant that if you manually split the lines (so you don’t have very long lines), it shouldn’t be a problem - is that the case?



  • Yes I did split the lines, without any result.
    I have done many extra tests but I have not found a solution.
    I am disappointed :-(

    0_1648221404653_Screenshot .png