Notice: The Monaca & Onsen UI Community Forum is shutting down.

For Onsen UI bug reports, feature requests and questions, please use the Onsen UI GitHub issues page. For help with Monaca, please contact Monaca Support Team.

Thank you to all our community for your contributions to the forum. We look forward to hearing from you in the new communication channels.

Your app currently targets API level 28 and must target at least API level 29

  • I tried to build a new Android app APK and upload to Google Play Store but I’m getting the following error:

    “Your app currently targets API level 28 and must target at least API level 29 to ensure it is built on the latest APIs optimized for security and performance. Change your app’s target API level to at least 29”

    I have all the latest Build Environment Settings: Android 8.1.0, and I’ve checked the Cordova Plugins and the CLI is set to 9.0.0. What do I need to do to change API levels?


  • administrators

    In the Android section of your config.xml, try adding the following line (or amending if you already have this line):

    <preference name=“android-minSdkVersion” value=“29” />

  • Did not help by updating the config.xml. In another thread suggested to switch to Cordova CLI 9.0.0 for API level 28.

    According to Google, "Note: From 2 November 2020, app updates must target Android 10 (API level 29) or higher.* "

  • Nobody was using Monaca to build Android apps?

  • administrators

    Ah yes, you should also make sure you are using Cordova 9 with Monaca (this it the default). You can check in the Cordova Plugin Settings page what Cordova version you are using.

  • @emccorson iOS build version worked fine. Build Environment was set to 8.1.0. But under Cordova Plugin settings page it says 8.0.0, I could not change it. API 29 is Android 10, doesn’t it mean Monaca is 2 versions behind?

  • administrators

    You can still use API level 29 on the version of cordova-android used by Monaca.

    Make sure your setting is within the <platform name=“android”> section of your config.xml. You can also try setting android-targetSdkVersion to 29.

  • Thank you @emccorson
    I added
    <preference name=“android-minSdkVersion” value=“29” />
    <preference name=“android-targetSdkVersion” value=“29” />
    to the config.xml file in the Android section at it worked