Notice: The Monaca & Onsen UI Community Forum is shutting down.

For Onsen UI bug reports, feature requests and questions, please use the Onsen UI GitHub issues page. For help with Monaca, please contact Monaca Support Team.

Thank you to all our community for your contributions to the forum. We look forward to hearing from you in the new communication channels.

Script Errors when running the App



  • Insecure content blocked gap://ready. CSP meta changed in index. Still not working.

    We’ve updated the meta tag for the content security policy, and //ready is still blocked before the rest of the app content loads. Is there some some other way to whitelist //ready?

    Here’s the important part of the index.html
    <!DOCTYPE HTML>
    <html>
    <head>
    <meta charset=“utf-8”>
    <meta http-equiv=“Content-Security-Policy” content=“default-src * data: gap: content: https://ssl.gstatic.com; style-src * ‘unsafe-inline’; script-src * ‘unsafe-inline’ ‘unsafe-eval’”>
    <meta name=“apple-mobile-web-app-capable” content=“yes” />
    <meta name=“viewport” content=“width=device-width” />
    <script src=“components/loader.js”></script>
    <link rel=“stylesheet” href=“components/loader.css”>
    <script type=‘text/javascript’>
    var ref = null;
    function onLoad() {
    document.addEventListener(“deviceready”, onDeviceReady, false);
    }

    Here’s the pertinent stuff from config.xml. The last 3 allow-navigation were desperate attempts.

    <content src=“index.html”/>
    <allow-navigation href=""/>
    <allow-intent href="
    "/>
    <allow-intent href=“tel:"/>
    <allow-intent href="sms:
    ”/>
    <allow-intent href=“mailto:"/>
    <allow-intent href="geo:
    ”/>
    <allow-intent href=“http:///”/>
    <allow-intent href=“https:///”/>
    <allow-navigation href=“http:///” />
    <allow-navigation href=“https:///” />
    <allow-navigation href=“data:*” />
    0_1595528343151_script.jpg



  • @gwclubexpress,

    Try adding https; after ‘unsafe-eval’.
    So content="… ‘unsafe-eval’ https;"

    HTH,
    Jamal



  • Did not help still getting the same error. Any other ideas?