Notice: The Monaca & Onsen UI Community Forum is shutting down.

For Onsen UI bug reports, feature requests and questions, please use the Onsen UI GitHub issues page. For help with Monaca, please contact Monaca Support Team.

Thank you to all our community for your contributions to the forum. We look forward to hearing from you in the new communication channels.

Splash screen never works

  • hey , i have problem with the splash screen , after i select image as Storyboard (for ios) then i select hide by javascript , fade splash screen , show splash spinner etc. but it i seems nothing gets effected , after i select my settings , i am saving it and dowloading the project from monaca lokalkit and it changes my config.xml naturally , then i hit run on local kit but nothing shows up as splash screen on phone , it only shows the debugger icon as splash screen , not the image i set and it is not hiding by javascript , i tried to add manuel settings in xml but it only changes the fade out duration , not the image of splash screen or anything else , and if i try to upload from lokalkit it is uploading my old xml i guess even i downloaded a fresh copy from ide after i made the settings for splash screen , is someone has same issue or any information about it ? , i tried to splash screen cordova plugin but no success for some reason , thank you for your help

  • administrators

    When you save your settings in the iOS settings page, does your config.xml get updated? And when you build your app do the changes to config.xml remain?

    Also, it might be obvious, but if you’re selecting to hide by JavaScript you need to put navigator.splashscreen.hide() somewhere in your code.

    It might be worth trying it without Localkit, just using Monaca Cloud IDE instead. Just in case it is a localkit problem.