Monaca Onsen UI Discord Chat Github Repo

Missing app icon on IOS build



  • When I build the debug app for IOS and installed on my iphone, I only see the default cordova icon, instead of the image that I uploaded on Monaca Cloud IDE.

    How can I see the icon image correctly?

    I already upload the .png images without success:
    0_1573866120239_icons_that_i_upload.png

    Image expected on for the app icon:
    0_1573866178378_expected.png

    Actual:
    0_1573866191525_actual.png

    What is the solution for this?
    Thank you in advance



  • @dgtodo24 said in Missing app icon on IOS build:

    When I build the debug app for IOS and installed on my iphone, I only see the default cordova icon, instead of the image that I uploaded on Monaca Cloud IDE.

    How can I see the icon image correctly?

    I already upload the .png images without success:
    0_1573866120239_icons_that_i_upload.png

    Image expected on for the app icon:
    0_1573866178378_expected.png

    Actual:
    0_1573866191525_actual.png

    What is the solution for this?
    Thank you in advance

    I am also have the same problem.
    Although I have uploaded my App Icon files to Monaca successfully, when I generate the IPA file, the IPA keeps showing the Cordova icon as the App Icon.



  • Any resolution on that? I am facing the same issue.



  • No, no resolution yet. I’m paying a plan for this and I didn’t have any response yet, so I’ll cancel that. TERRIBLE SERVICE!



  • I too am experiencing the same issue. I have uploaded my iOS and Android icons and they are showing in the App Settings in Monaca cloud console but defaults to the Cordova icon when building both iOS or Android apps whether it be a simulator build, custom debugger build or release build.

    @monaca team – please help to rectify this issue.



  • I have reported this issue for more than a month now, and I have two ongoing subscribed accounts, but under different client emails AND that has also driven me crazy:

    1. I can’t request support with my own email, the damn emails only go to the clients and they have to forward and respond on behalf of me, is this a joke?
    1. The support has told me nonsense like delete everything and make everything anew. Is this also a joke? Do you think I have nothing else to do but that?

    My registered paid accounts:

    Contact@jahulien.com
    Talentslive7@gmail.com

    If you’re not gonna fix this anytime soon I’m gonna cancel both accounts and get rid of this terrible support once and for all. Two years ago when I signed up there was live chat and smart tech, now I’m just getting rehashed simplistic answers that actually don’t help one bit but manage nicely to waste my time.

    Your support has definitely regressed and I’m reaching my limit here.


  • administrators

    This seems to be an intermittent bug and we are still looking for a way to consistently reproduce it.

    If anyone is still facing this problem consistently with one of their projects, please contact the support team and they will attempt to reproduce the problem using your project. Please provide the platform (iOS, Android) and the build type (debug, release, simulator) that the problem is occuring with. In general, this seems to be showing up mostly with iOS.

    @j4hangir The support team have tested your project for this problem but the icon was showing correctly. If you are still having the problem, please let the support team know with the information listed above. The support ticket replies go the email of the account used to create the ticket - if this is different for you, please also pass this to the support team. They can also email you directly until the problem is solved.



  • @emccorson I opened a ticket on this because my app 100% of the time gets the cordova icon instead of the one I set in my app settings. App settings show it correctly but doesn’t use those when it builds app. I have downloaded my ipa file and extracted the payload and have confirmed that all app icons in the app are the cordova ones and not mine. This is the final thing for me to resolve before I can deliver my app to the store. Any help would be amazing! Thanks much!

    Monaca Support #2011683



  • @j4hangir I put in a ticket for this issue and they came back with my config.xml file didn’t have the <icon src="… code for iOS app icons. It is suppose to add it by itself when you add an icon but it wasn’t. I added those icons into the config.xml file and compiled and BAM! worked!


  • administrators

    For future reference, the icon lines you should need for the device app icons (not the app store ones) with Monaca are:

    <icon src="/res/ios/icon/icon.png" width="57" height="57"/>
    <icon src="/res/ios/icon/icon@2x.png" width="114" height="114"/>
    <icon src="/res/ios/icon/icon-72.png" width="72" height="72"/>
    <icon src="/res/ios/icon/icon-72@2x.png" width="144" height="144"/>
    <icon src="/res/ios/icon/icon-60.png" width="60" height="60"/>
    <icon src="/res/ios/icon/icon-60@2x.png" width="120" height="120"/>
    <icon src="/res/ios/icon/icon-60@3x.png" width="180" height="180"/>
    <icon src="/res/ios/icon/icon-76.png" width="76" height="76"/>
    <icon src="/res/ios/icon/icon-76@2x.png" width="152" height="152"/>
    <icon src="/res/ios/icon/icon-40.png" width="40" height="40"/>
    <icon src="/res/ios/icon/icon-40@2x.png" width="80" height="80"/>
    <icon src="/res/ios/icon/icon-50.png" width="50" height="50"/>
    <icon src="/res/ios/icon/icon-50@2x.png" width="100" height="100"/>
    <icon src="/res/ios/icon/icon-small.png" width="29" height="29"/>
    <icon src="/res/ios/icon/icon-small@2x.png" width="58" height="58"/>
    <icon src="/res/ios/icon/icon-small@3x.png" width="87" height="87"/>
    <icon src="/res/ios/icon/icon-83.5@2x~ipad.png" width="167" height="167"/>