Cannot reach forum on iPhone and T-Mobile & Verizon cellular networks

  • I am not sure if this the right section of the forum, but here we go.

    In the USA, while on the road, I cannot reach over T-Mobile LTE celluar network either using Safari or Chrome mobile browsers.

    1. When using an iPhone over T-Mobile LTE cellular network which I am mainly using, I cannot reach the website, however on any other wifi WIFI it loads fine.

    I contacted T-Mobile tech support and they had the same issue. This is only site I am having issues with.

    Safari browser:


    Chrome browser:

    On Chrome, the error is more descriptive:
    The site can’t provide a secure connection send an invalid response


    1. A friend tried it On a iPhone using Verizon over WIFI using Chrome browser: and he got the following:


    Note: I can reach but not on T-Mobile.

  • Monaca

    @jamal This is the first time we’ve heard that our Community can’t be accessed from the US. Can you please try again? Is the issue still there?

  • @khemry, yes this still an issue.
    This issue is only iPhones as shown in the screenshots.

    Here is video link showing the issue. BTW, I pasted

  • Monaca

    @jamal said:

    This issue is only iPhones as shown in the screenshots.

    So it only happens on iPhone? It’s okay on Android devices? That’s weird.

  • @khemry, yes it only happens on iPhones.

    A friend of mine tried it on a Samsung Galaxy 8 and it showed up fine.

    Could it be the SSL certificate that iPhone OS is sensitive to or an iPhone 11.x bug, currently on 11.1 ? Yes, it’s weird.
    I’ll contact Apple tomorrow to see if they have an answer.

  • @khemry, I just contacted Apple tech support and they have the same issue even on A&T network.

    I uploaded the iPhone log files so they can investigate further. I’ll let you know once I hear from them.

  • Monaca

    @jamal Thanks for the follow-up information. I hope you hear positive response from Apple. Good luck! :+1:

Log in to reply