ngx-onsenui vs onsenui



  • On https://onsen.io/v2/guide/angular2/ you say that I can add Angular 2+ support by requesting:

    npm install onsenui ngx-onsenui --save

    but that doesn’t work because the modules are not compatible.

    If I issue the command followed by an immediate npm list, I see the error message:

    npm ERR! peer dep missing: onsenui@~2.3.3, required by ngx-onsenui@4.0.0-rc.1


  • Onsen UI

    Hi, @vgriffin!

    You can fix that kind of error by manually running npm install onsenui@~2.3.3 --save.

    The fundamental cause of the error is that ngx-onsenui is not yet supporting the latest version of onsenui (2.5.3).
    I am working on updating ngx-onsenui now. Thank you.



  • I did some internal exploration and saw that ngx-onsenui/CHANGELOG.md includes a line saying that a bug fix had removed that dependency, so I removed the dependency as a workaround… I made the assumption that there will be a new release before I’m close enough to real testing for it to matter. If I run into other problems (like one I found with ons-list-item that I’ll describe in another post), I’ll test with the older onsenui. (I’ve written a lot of system-level code in many languages.) I’ll keep using this bandage until I find something I can’t work around or you release the version you’re working on!



  • @asial-matagawa

    I tried to install that version and got the following error, which does not occur for the current version of onsenui:

    npm ERR! code 129
    npm ERR! Command failed: C:\Program Files (x86)\Git\cmd\git.CMD clone --depth=1 -q -b 1.0.0-rc.3+mod.20170410.1 git:
    //github.com/OnsenUI/custom-elements.git C:\Users\Valerie\AppData\Roaming\npm-cache_cacache\tmp\git-clone-aa33e141
    –config core.longpaths=true
    npm ERR! error: unknown option `config’

    I’m running Windows 10. My git version is 1.7.6.msysgit.0

    I know there’s a later version available, but don’t have time right now to do that upgrade. I’ll try to do it later today so I can test the ons-list problem against a more supported version of onsen


  • Onsen UI

    @vgriffin
    That error on Git was already fixed in Onsen UI 2.5.1.
    https://github.com/OnsenUI/OnsenUI/commit/60687db5f857adf00aaa2e7b9b94da43d3afe85b#diff-b9cfc7f2cdf78a7f4b91a753d10865a2

    But as I mentioned in the previous reply, ngx-onsenui currently depends on Onsen UI 2.3.x.
    I will fix this problem as soon as possible. Thank you.


Log in to reply